Problema balordo e banale allo stesso tempo: il servizio del prodotto “Backup&Replication” di Veeam, servizio che si incarica di effettuare la replica ed il backup delle macchine virtuali presenti su un determinato host, non ne vuole sapere di avviarsi, nonostante tutti i controlli del caso, nonostante fino a pochi istanti prima tutto funzionasse a meraviglia. Prima di disinstallare il prodotto e reinstallarlo nuovamente, ponetevi la seguente domanda: per caso (per “n” motivi che ora non sto a sindacare) avete cambiato il nome del computer o della VM che ospita Veeam Backup&Replication?

Ebbene, sappiate che in questo caso il povero Veeam non riesce a trovare il database nel quale sono memorizzati tutti i suoi dati, in quanto il percorso di localizzazione comprende anche il nome della macchina su cui è ospitato tutto l’ambaradan…

Il rimedio è semplice: bisogna modificare un paio di chiavi del registro di sistema della macchina per poter variare il nome del computer e riallinearlo con quello nuovo assegnatogli imprudentemente (cioè senza aver fatto i conti col software permaloso), modifiche da effettuare eseguendo il comando “REGEDIT”:

HKLM\SOFTWARE\Veeam\Veeam Backup and Replication\SqlServerName

HKLM\SOFTWARE\Veeam\Veeam Backup Catalog\CatalogSharedFolderPath

Riavviate la macchina sulla quale è installato il Veeam ed il gioco è fatto: backup e repliche saranno di nuovo in funzione.

Il servizio di Veeam Backup&Replication non si avvia
Tagged on:         

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *